Software Experimente mit Linux

Musikwiedergabe über PC und Mac

Beitragvon Buellerich » 17.04.2018, 14:40

Moin Us

also ganz so stark wie Du habe ich die Unterschiede nicht feststellen können, eher subtiler.

Ich selber bin zu Windows basiertem Computer Audio zurückgekehrt, weil es m.E. zumindest mit JPLAY klanglich überlegen war. Ich muss allerdings dazu sagen, dass ich über Linux nur Daphile und WTF getestet habe. Beide gehen allerdings über den Alsa Treiber. Interessant wäre vielleicht noch audiophile Linux oder snakeoil.
Welche Registryeinträge wurden denn von Windows ignoriert?
Bist Du mit Admin Rechten unterwegs?
Bild
Buellerich
Aktiver Hörer
 
Beiträge: 198
Registriert: 01.02.2015, 00:08

Beitragvon ZZTop » 17.04.2018, 15:06

Windows 10 ignoriert so ziemlich alle wesentlichen Settings, bzw. überschreibt diese nach Lust und Laune.
Updates, search-Indexer, Cortana, Superfetch... um nur ein paar zu nennen. Selbst wenn in der Registry deaktviert, nach ein paar Neustarts sind sie alle wieder da.
Ob ich Admin bin? Ich dachte schon, aber werde immer wieder aufgefordert für gewisse Vorgänge Admin Rechte zu verwenden. Da klicke ich halt auf "ja"

Vielleicht habe ich ja bei der Installation etwas verkehrt gemacht. Hat hier noch jemand JRiver unter Linux am laufen?

greetz
Uwe
Bild
ZZTop
Aktiver Hörer
 
Beiträge: 115
Registriert: 15.03.2012, 15:27

Beitragvon uli.brueggemann » 17.04.2018, 15:54

ZZTop hat geschrieben:Windows 10 ignoriert so ziemlich alle wesentlichen Settings, bzw. überschreibt diese nach Lust und Laune.
Updates, search-Indexer, Cortana, Superfetch... um nur ein paar zu nennen. Selbst wenn in der Registry deaktviert, nach ein paar Neustarts sind sie alle wieder da.

Schau Dir doch mal das ShutUp10 von O&O an. Das funktioniert ziemlich gut.

Grüsse
Uli
Bild
uli.brueggemann
Aktiver Hersteller
 
Beiträge: 3549
Registriert: 23.03.2009, 16:58
Wohnort: 33442

Beitragvon ZZTop » 17.04.2018, 20:04

Scheisse! jetzt habe ich mir mein Linux Mint zerschossen.
Ich wollte mit der disk utility einstellen, dass die Partition mit den Musikdaten automatisch beim Start geladen wird.
Jetzt fährt Linux nicht mehr hoch sondern bringt Meldungen wie:
[ 95.722897 ]nouveau 0000:03........ bus MMIO write of00000002 FAULT at4188ac [ IBUS ]

wobei alle paar Minuten der erste Block in [ ] um ca. 25.000000 gröger wird, der Rest bleibt gelch. Das geht stundenlang, bis ich abschalte.

hat jemand nen Tipp?
Bild
ZZTop
Aktiver Hörer
 
Beiträge: 115
Registriert: 15.03.2012, 15:27

Beitragvon Sire » 17.04.2018, 22:35

Hallo Uwe,

mit der Arbeitsweise des "disk utility" kenne ich mich zwar nicht aus, ich vermute aber, dass die /etc/fstab verändert wurde.

Kannst Du Deinen Rechner mit einem Live-System booten? Falls ja, dann finde auf Deiner Festplatte die Datei /etc/fstab der LInux-Mint-Installation und poste sie hier.

Viele Grüße

Klaus

PS: Ich hatte mir eben die Fehlermeldung nicht richtig angeschaut, vermutlich ist es doch was anderes. Lässt eher auf ein Problem mit den noveau-Modulen der Nvidia-Grafikkarte schließen.
Bild
Sire
Aktiver Hörer
 
Beiträge: 258
Registriert: 02.12.2013, 15:01

Beitragvon frankl » 18.04.2018, 23:25

ZZTop hat geschrieben:Jetzt fährt Linux nicht mehr hoch sondern bringt Meldungen wie:
[ 95.722897 ]nouveau 0000:03........ bus MMIO write of00000002 FAULT at4188ac [ IBUS ]

Hallo Uwe,

bei solchen Problemen hilft meist die Lieblingssuchmaschine schnell weiter. In diesem Fall würde ich mal "nouveau MMIO write FAULT" oder ähnliches eingeben.

Bitte an die Moderation: Dieser Thread ist nicht für den Austausch über Konfiguratiionsprobleme von Windows 10 oder die Installation spezifischer Linux Varianten gedacht. Vielleicht kann dieser Beitrag und die vorhergehenden zu Win 10 ins Archiv verschoben werden?

Viele Grüße,
Frank
Bild
frankl
Aktiver Hörer
 
Beiträge: 396
Registriert: 20.01.2013, 02:43
Wohnort: Aachen

Beitragvon frankl » 18.04.2018, 23:53

Hallo Daniel,
vielen Dank für Deinen Bericht über den Einsatz von 'playhrt'. Du beschreibst ganz richtig, dass man zu Anfang ein bisschen mit den vielen Parametern herumprobieren muss. Aber es freut mich, dass Du dann eine befriedigende Einstellung finden konntest.

Deinen Vergleich verschiedener Timer finde ich auch sehr interessant. Auf den Rechnern, auf denen ich die Programme selbst probiert habe, gab es allerdings immer nur einen hochauflösenden Timer, so dass sich die Frage nach einem Vergleich nie ergeben hat.

In Deinem Skript wird zum Schluss 'playshm' aufgerufen. Ist das ein Tippfehler und es ist 'playhrt' gemeint?

Zu den 'taskset' Kommandos: Ich sorge in meinem Abspielskript auf meinem Convolver-Rechner auch dafür, dass keine ungewollten Prozesse auf dem CPU-Kern laufen, auf dem der wichtigste Prozess (in meinem Fall 'bufhrt', bei Dir 'playhrt') gestartet wird. Das mache ich so, wie von Simon vorgeschlagen, also zuerst
wird die CPU ausgeschaltet:
echo 0 > /sys/devices/system/cpu/cpu1/online

und dann wieder eingeschaltet und die gewünschten Prozesse darauf mit 'taskset' gestartet.

Ich finde es bei mir übrigens am besten, das 'writeloop' (ohne realtime Priorität) und das 'bufhrt' (mit hoher realtime Priorität) auf dem gleichen CPU-Kern laufen zu lassen. Das könnte damit zu tun haben, dass unter Umständen nicht jede CPU jeden Speicherbereich gleich schnell ansprechen kann. Das muss nicht auf jeder Architektur gleich sein, aber wäre vielleicht einen Versuch wert.

Koala887 hat geschrieben:Der einzige Nachteil dabei ist, das Ganze spielt nicht gapless und bei Pause startet das Lied von vorne, was mich aber nicht besonders stört. Für den guten Klang macht man gerne ein paar Abstriche. 8)


Verstehe ich es richtig, dass Dein Skript durch 'mpd' für jedes ausgewählte Stück gestartet wird? Wenn ja, dann lässt sich in Bezug auf gapless wohl nichts verbessern.

In Deinem Skript könntest Du allerdings durchaus mehrere Stücke per 'wget' holen und dann hinterher alle diese Stücke als input-Dateien für 'sox' verwenden. Das sollte dann alle Stücke hintereinander gapless spielen. Könnte man 'mpd' dazu bringen, eine '.m3u' zu übergeben (die in jeder Zeile die URL zu einem Stück enthält)?

Viele Grüße,
Frank
Bild
frankl
Aktiver Hörer
 
Beiträge: 396
Registriert: 20.01.2013, 02:43
Wohnort: Aachen

Beitragvon Koala887 » 19.04.2018, 13:02

Hallo Frank,
frankl hat geschrieben:In Deinem Skript wird zum Schluss 'playshm' aufgerufen. Ist das ein Tippfehler und es ist 'playhrt' gemeint?

über 1000 Zugriffe und du bist der Erste dem es auffällt. :wink:
Bei playhrt hatte ich die Möglichkeit vermisst, wie bei bufhrt, die shared Memory Dateien von writeloop direkt einzulesen. Also habe ich mir kurzerhand selbst ein Programm zusammen kopiert, welches die shm-Dateien per memcpy und mmap direkt in den Speicherbereich der Soundkarte kopiert. Wenn jemand Interesse hat, kann ich es gerne zur Verfügung stellen.
Davon habe ich dann auch noch eine 2. Version erstellt, bei der der komplette Fehlerauswertungs- und Statistikcode entfernt ist, was mMn noch einen Tick besser klingt :D
frankl hat geschrieben:Das mache ich so, wie von Simon vorgeschlagen, also zuerst
wird die CPU ausgeschaltet:
echo 0 > /sys/devices/system/cpu/cpu1/online
und dann wieder eingeschaltet und die gewünschten Prozesse darauf mit 'taskset' gestartet.

Hier ist es aber möglich, dass Linux neue Prozesse trotzdem auf dem Kern startet, oder laufende Prozesse dorthin verschiebt. Mit isolcpus wird das unterbunden.
frankl hat geschrieben:Könnte man 'mpd' dazu bringen, eine '.m3u' zu übergeben (die in jeder Zeile die URL zu einem Stück enthält)?

Ich bin mir jetzt nicht ganz sicher, aber ich glaube man kann auch die komplette Playlist abrufen. Da es mich bis jetzt nicht gestört hat, habe ich das aber noch nicht weiter verfolgt.

Schöne Grüße
Daniel
Bild
Koala887
Aktiver Hörer
 
Beiträge: 531
Registriert: 27.12.2010, 18:23
Wohnort: Eltmann, Unterfranken

Beitragvon Bernd Peter » 19.04.2018, 17:32

Hallo Daniel,

über 1000 Zugriffe und du bist der Erste dem es auffällt.


mir ist das auch sofort aufgefallen, richtig heißt es ja playmate, oder?

Gruß

Bernd Peter
Bild
Bernd Peter
Aktiver Hörer
 
Beiträge: 3219
Registriert: 04.05.2010, 19:37

Beitragvon frankl » 26.04.2018, 23:28

Koala887 hat geschrieben:Hallo Frank,
frankl hat geschrieben:In Deinem Skript wird zum Schluss 'playshm' aufgerufen. Ist das ein Tippfehler und es ist 'playhrt' gemeint?

über 1000 Zugriffe und du bist der Erste dem es auffällt. :wink:
Bei playhrt hatte ich die Möglichkeit vermisst, wie bei bufhrt, die shared Memory Dateien von writeloop direkt einzulesen. Also habe ich mir kurzerhand selbst ein Programm zusammen kopiert, welches die shm-Dateien per memcpy und mmap direkt in den Speicherbereich der Soundkarte kopiert. Wenn jemand Interesse hat, kann ich es gerne zur Verfügung stellen.

Hallo Daniel,

danke für Deine Erklärungen. Ich gebe zu, dass mir bei meiner Frage gar nicht bewusst war, dass ich in 'playhrt' noch gar nicht die Input-Variante aus dem shared memory implementiert hatte. Ich habe das mal auf meine TODO Liste geschrieben.

Koala887 hat geschrieben:Davon habe ich dann auch noch eine 2. Version erstellt, bei der der komplette Fehlerauswertungs- und Statistikcode entfernt ist, was mMn noch einen Tick besser klingt :D


Gute Idee. Das habe ich gleich mal probiert und das macht bei mir auch den Klang einen hörbaren Tick besser. Es spielt hier vielleicht eine Rolle, dass der Code der zentralen Schleife möglichst kompakt ist, denn für die Rechenzeit sind die paar 'if'-Abfragen, durch die Code übersprungen wird, irrelevant.

Ich werde mir überlegen, ob ich so eine über einen Schalter wählbare Kompaktversion des Codes in das Programm einbaue.

Koala887 hat geschrieben:
frankl hat geschrieben:Das mache ich so, wie von Simon vorgeschlagen, also zuerst
wird die CPU ausgeschaltet:
echo 0 > /sys/devices/system/cpu/cpu1/online
und dann wieder eingeschaltet und die gewünschten Prozesse darauf mit 'taskset' gestartet.

Hier ist es aber möglich, dass Linux neue Prozesse trotzdem auf dem Kern startet, oder laufende Prozesse dorthin verschiebt. Mit isolcpus wird das unterbunden.


Das habe ich jetzt auf meinem 4-Core Odroid Convolver-Rechner auch mal probiert (dazu muss man die Kernel-Parameter-Zeile in der 'uboot.ini' suchen und editieren). Es ist sehr hübsch anzusehen, dass jetzt auf den CPUs 1 bis 3 nur noch die zugehörigen Scheduler-Kernel-Prozesse und die Programme meiner Abspiel-Pipe laufen. Die vorher da herumlungernden Prozesse (die allerdings auch nach Wochen keine CPU-Zeit verbraucht hatten) sind nun alle auf die CPU 0 verbannt. Klanglich konnte ich gegen mein vorheriges Setup aber hier keinen Unterschied ausmachen.

Viele Grüße,
Frank
Bild
frankl
Aktiver Hörer
 
Beiträge: 396
Registriert: 20.01.2013, 02:43
Wohnort: Aachen

Vorherige

Zurück zu Computer-HiFi

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste